.net project unit test naming

Just wanted to do a quick post on unit test method naming, in particular with .net projects;

Most test suites I come across are title cased:

public void LikeThis()

This annoys me. I find long method names hard to read, and easy to miss detail

Example:

public void DoesNotReImplementAdditionalInterfaceAlreadyImplementedByInterceptedClass()

is not a readable as:

public void does_not_reImplement_additional_interface_already_implemented_by_intercepted_class()